<!DOCTYPE html>
<html lang="en"
      dir="ltr" 
  xmlns:fb="http://www.facebook.com/2008/fbml"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="icon" type="image/png" sizes="32x32" href="/sites/eastlandcountytoday.etypegoogle5.com/files/favicons/favicon-32x32.png" />
<link rel="icon" type="image/png" sizes="16x16" href="/sites/eastlandcountytoday.etypegoogle5.com/files/favicons/favicon-16x16.png" />
<link rel="manifest" href="/sites/eastlandcountytoday.etypegoogle5.com/files/favicons/manifest.json" />
<link rel="mask-icon" href="/sites/eastlandcountytoday.etypegoogle5.com/files/favicons/safari-pinned-tab.svg" color="#5bbad5" />
<meta name="theme-color" content="#ffffff" />
<link rel="apple-touch-icon" sizes="180x180" href="/sites/eastlandcountytoday.etypegoogle5.com/files/favicons/apple-touch-icon.png" />
<meta name="description" content="Conservative Republican Candidate Jon Glenn for Justice of the Peace Pct. 1 Equality, Fairness, Respect" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.eastlandcountytoday.com/eastland-telegram/jon-glenn-candidate-eastland-county-jp-pct-1" />
<link rel="shortlink" href="https://www.eastlandcountytoday.com/node/195245" />
<meta property="og:site_name" content="Eastland County Today" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.eastlandcountytoday.com/eastland-telegram/jon-glenn-candidate-eastland-county-jp-pct-1" />
<meta property="og:title" content="Jon Glenn Candidate For Eastland County JP Pct. #1" />
<meta property="og:description" content="Conservative Republican Candidate Jon Glenn for Justice of the Peace Pct. 1 Equality, Fairness, Respect" />
<meta property="og:updated_time" content="2018-02-05T13:00:56-06:00" />
<meta property="article:published_time" content="2018-02-05T13:00:56-06:00" />
<meta property="article:modified_time" content="2018-02-05T13:00:56-06:00" />
    <title>Jon Glenn Candidate For Eastland County JP Pct. #1 | Eastland County Today</title>
  <link type="text/css" rel="stylesheet" href="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/css/css_0GmTL6HHlk1IMbUNAQqtx5Mu79hhIH4FBiAaFAplWeA.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/css/css_7F1Oek8snhajJhq-zMR97fUyDwku8CJAbjc0Miny3pY.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/css/css_ypATbsZfrqXjMzgZjoL5zHCbkJWFaJDzpemiIGd8MJY.css" media="all" />
<style type="text/css" media="screen">
<!--/*--><![CDATA[/*><!--*/
.site-logo img {max-width: 1400px !important;}
/*]]>*/-->
</style>
  <script type="text/javascript" src="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/js/js_RC7d2_dhfBsqLAPQvLz26Tw_1pi8VuJA8XTLntJVGuM.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/js/js_8pEoWnUr8ijKw1SExt7kT6gNr85MGL-IZJyQGXvJRP0.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.slots["tpa_northsidebar"] = googletag.defineSlot("/116205717/TPA-Westsidebar", [300, 250], "dfp-ad-tpa_northsidebar")
  .addService(googletag.pubads());
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.slots["tpa_northleaderboard"] = googletag.defineSlot("/116205717/TPA-Westleaderboard", [728, 90], "dfp-ad-tpa_northleaderboard")
  .addService(googletag.pubads());
//--><!]]>
</script>
<script type="text/javascript" src="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/js/js_c9S7L28GiD9hlQGPOAZ-TmAjXzauQOFTS3F37BGHtCQ.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();
//--><!]]>
</script>
<script type="text/javascript" src="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/js/js_GKYub58EhDH712UGwDC56vnnE6rsjXxl_X4Qpo1KkA0.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-33785089-1", {"cookieDomain":".eastlandcountytoday.com"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56e774978692f861"></script>
<script type="text/javascript" src="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/js/js_rjYH_eRa7L_D29070OpSiLnDi0OfNB0FR3rwIO0kzSs.js"></script>
<script type="text/javascript" src="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/js/js_qJzMDf1wcQ8GdgSdl6Ib9WA_IEXVqLMAC1eLrkibEIg.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"cni","theme_token":"a34sDpwnq9zi2O-m_euQyQE-T_yanTTIbqPmXM6DtpE","js":{"sites\/all\/modules\/addthis\/addthis.js":1,"misc\/jquery.js":1,"misc\/jquery.once.js":1,"0":1,"https:\/\/www.googletagservices.com\/tag\/js\/gpt.js":1,"misc\/drupal.js":1,"1":1,"2":1,"sites\/all\/modules\/simpleads\/simpleads.js":1,"sites\/all\/modules\/simpleads\/modules\/simpleads_campaigns\/simpleads_campaigns.js":1,"3":1,"sites\/all\/modules\/external\/external.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"4":1,"\/\/s7.addthis.com\/js\/300\/addthis_widget.js#pubid=ra-56e774978692f861":1,"sites\/all\/libraries\/superfish\/jquery.hoverIntent.minified.js":1,"sites\/all\/libraries\/superfish\/superfish.js":1,"sites\/all\/libraries\/superfish\/supersubs.js":1,"sites\/all\/modules\/superfish\/superfish.js":1,"sites\/all\/themes\/cni\/js\/jquery.color.js":1,"sites\/all\/themes\/cni\/js\/jquery-glowing.js":1,"sites\/all\/themes\/cni\/js\/scripts.js":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/aggregator\/aggregator.css":1,"sites\/all\/modules\/calendar\/css\/calendar_multiday.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"sites\/all\/modules\/date\/date_repeat_field\/date_repeat_field.css":1,"modules\/field\/theme\/field.css":1,"modules\/node\/node.css":1,"modules\/search\/search.css":1,"sites\/all\/modules\/simpleads\/simpleads.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ed_classified\/theme\/classified.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/libraries\/superfish\/css\/superfish.css":1,"sites\/all\/libraries\/superfish\/css\/superfish-navbar.css":1,"sites\/all\/libraries\/superfish\/style\/space.css":1,"sites\/all\/themes\/cni\/css\/normalize.css":1,"sites\/all\/themes\/cni\/css\/formalize.css":1,"sites\/all\/themes\/cni\/css\/grid_12.css":1,"sites\/all\/themes\/cni\/css\/layout.css":1,"sites\/all\/themes\/cni\/css\/jcarousel.css":1,"sites\/all\/themes\/cni\/css\/galleria.css":1,"sites\/all\/themes\/cni\/css\/theme.css":1,"sites\/all\/themes\/cni\/css\/responsive.css":1,"sites\/all\/themes\/cni\/css\/ads.css":1,"0":1}},"externalpdf":1,"jcarousel":{"ajaxPath":"\/jcarousel\/ajax\/views"},"simpleads":{"url":{"ckeditor":"\/simpleads\/dashboard\/ckeditor"},"modulepath":"sites\/all\/modules\/simpleads"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip","trackDomainMode":1},"urlIsAjaxTrusted":{"\/eastland-telegram\/jon-glenn-candidate-eastland-county-jp-pct-1":true},"superfish":{"1":{"id":"1","sf":{"pathClass":"active-trail","pathLevels":"2","animation":{"opacity":"show"},"speed":"\u0027normal\u0027","autoArrows":false,"dropShadows":true,"disableHI":false},"plugins":{"supposition":false,"bgiframe":false,"supersubs":{"minWidth":"12","maxWidth":"27","extraWidth":1}}}}});
//--><!]]>
</script>
    <meta name="viewport"
          content="width=device-width, initial-scale=1, maximum-scale=1">
    <link href='//fonts.googleapis.com/css?family=Lato' rel='stylesheet'
          type='text/css'>
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
</head>
<body class="html not-front not-logged-in one-sidebar sidebar-first page-node page-node- page-node-195245 node-type-video sidebars-split eastland-telegram jon-glenn-candidate-eastland-county-jp-pct-1">
<div id="fb-root"></div>
<script>(function (d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(s);
        js.id = id;
        js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
        fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>
<div id="skip-link">
    <a href="#main-content"
       class="element-invisible element-focusable">Skip to main content</a>
</div>
<div id="page-top">

        <nav id="user-menu" class="clearfix">
          <div class="region region-user-menu">
    <div id="block-system-user-menu"
     class="block block-system block-menu">
    <div class="block-inner">

                      <h3 class="title">
              <span>User menu</span></h3>
            
        <div class="content">
          <ul class="menu"><li class="first leaf"><a href="/e-edition" title="Link to e-Edition."><span>Subscribe</span></a></li>
<li class="leaf"><a href="/advertise" title=""><span>Advertise</span></a></li>
<li class="leaf"><a href="http://www.instantimagegallery.com/iig/c/885" title=""><span>Buy Photos</span></a></li>
<li class="leaf"><a href="http://www.eastlandcrimestoppers.com/" title=""><span>County Scanner</span></a></li>
<li class="last leaf"><a href="http://archive.eastlandcountytoday.com/" title=""><span>Archive</span></a></li>
</ul>        </div>

    </div>
</div>
<div id="block-search-form"
     class="block block-search">
    <div class="block-inner">

                  
        <div class="content">
          <form onsubmit="if(this.search_block_form.value==&#039;Search&#039;){ alert(&#039;Please enter a search&#039;); return false; }" action="/eastland-telegram/jon-glenn-candidate-eastland-county-jp-pct-1" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-3TSt8YrgPFqTEU9lLFS9QX4lpw_Dy0c0oPQI44Qklt8" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>        </div>

    </div>
</div>
<div id="block-etype-social"
     class="block block-etype">
    <div class="block-inner">

                  
        <div class="content">
          
  <ul class="social-links"><li><a class="facebook" href="https://www.facebook.com/eastlandcountynews"></a></li><li><a class="rss" href="/rss.xml"></a></li></ul>        </div>

    </div>
</div>
  </div>
              </nav>
  
    <div class="page-inner container_12">
        <div class="header-wrapper clearfix">
            <div class="header-wrapper-inner grid_12">
                <header>

                                        <div class="site-logo">
                      <a href="/"><img
                                  src="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/banner_for_website.jpg"
                                  alt="Eastland County Today"/></a>
                      </div>                  
                </header>

            </div>
        </div>

    </div>
</div>

    <div class="main-menu-wrapper clearfix">
        <div class="main-menu-wrapper-inner">
            <nav id="main-menu">
                <div class="region region-main-menu">
    <div id="block-superfish-1"
     class="block block-superfish">
    <div class="block-inner">

                      <h3 class="title">
              <span>Main menu</span></h3>
            
        <div class="content">
          <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-navbar sf-style-space sf-total-items-9 sf-parent-items-6 sf-single-items-3"><li id="menu-656-1" class="first odd sf-item-1 sf-depth-1 sf-no-children"><a href="/" title="" class="sf-depth-1"><span>Home</span></a></li><li id="menu-2503-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/eastland-telegram" title="Eastland Telegram" class="sf-depth-1 menuparent"><span>Eastland Telegram</span></a><ul><li id="menu-2588-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/eastland-sports" title="Eastland Sports" class="sf-depth-2"><span>Eastland Sports</span></a></li><li id="menu-2649-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/eastland-lifestyle" title="Eastland Lifestyle" class="sf-depth-2"><span>Eastland Lifestyle</span></a></li><li id="menu-2648-1" class="last odd sf-item-3 sf-depth-2 sf-no-children"><a href="/eastland-obits" title="Eastland Obits" class="sf-depth-2"><span>Eastland Obits</span></a></li></ul></li><li id="menu-1284-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/cisco-press" title="Cisco Press" class="sf-depth-1 menuparent"><span>Cisco Press</span></a><ul><li id="menu-2589-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/cisco-sports" title="Cisco Sports" class="sf-depth-2"><span>Cisco Sports</span></a></li><li id="menu-2652-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/cisco-lifestyle" title="Cisco Lifestyle" class="sf-depth-2"><span>Cisco Lifestyle</span></a></li><li id="menu-2651-1" class="last odd sf-item-3 sf-depth-2 sf-no-children"><a href="/cisco-obits" title="Cisco Obits" class="sf-depth-2"><span>Cisco Obits</span></a></li></ul></li><li id="menu-2422-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/ranger-times" title="Ranger Times" class="sf-depth-1 menuparent"><span>Ranger Times</span></a><ul><li id="menu-2590-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/ranger-sports" title="Ranger Sports" class="sf-depth-2"><span>Ranger Sports</span></a></li><li id="menu-2654-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/ranger-lifestyle" title="Ranger Lifestyle" class="sf-depth-2"><span>Ranger Lifestyle</span></a></li><li id="menu-2653-1" class="last odd sf-item-3 sf-depth-2 sf-no-children"><a href="/ranger-obits" title="Ranger Obits" class="sf-depth-2"><span>Ranger Obits</span></a></li></ul></li><li id="menu-2339-1" class="middle odd sf-item-5 sf-depth-1 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/rising-star" title="Rising Star" class="sf-depth-1 menuparent"><span>Rising Star</span></a><ul><li id="menu-2592-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/rising-star-sports" title="Rising Star Sports" class="sf-depth-2"><span>Rising Star Sports</span></a></li><li id="menu-2656-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/rising-star-lifestyle" title="Rising Star Lifestyle" class="sf-depth-2"><span>Rising Star Lifestyle</span></a></li><li id="menu-2655-1" class="last odd sf-item-3 sf-depth-2 sf-no-children"><a href="/rising-star-obits" title="Rising Star Obits" class="sf-depth-2"><span>Rising Star Obits</span></a></li></ul></li><li id="menu-2587-1" class="middle even sf-item-6 sf-depth-1 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/gorman-progress" title="Gorman Progress" class="sf-depth-1 menuparent"><span>Gorman Progress</span></a><ul><li id="menu-2593-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/gorman-sports" title="Gorman Sports" class="sf-depth-2"><span>Gorman Sports</span></a></li><li id="menu-2658-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/gorman-lifestyle" title="Gorman Lifestyle" class="sf-depth-2"><span>Gorman Lifestyle</span></a></li><li id="menu-2657-1" class="last odd sf-item-3 sf-depth-2 sf-no-children"><a href="/gorman-obits" title="Gorman Obits" class="sf-depth-2"><span>Gorman Obits</span></a></li></ul></li><li id="menu-2650-1" class="middle odd sf-item-7 sf-depth-1 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="https://etypeservices.com/SWF/LocalUser/Etypeclass1/Magazine30252/Full/index.aspx?II=30252" title="" class="sf-depth-1 menuparent"><span>Classifieds</span></a><ul><li id="menu-2425-1" class="firstandlast odd sf-item-1 sf-depth-2 sf-no-children"><a href="/classified-advertisement" class="sf-depth-2"><span>Place a Classified</span></a></li></ul></li><li id="menu-2170-1" class="middle even sf-item-8 sf-depth-1 sf-no-children"><a href="/contact" title="" class="sf-depth-1"><span>Contact Us</span></a></li><li id="menu-2660-1" class="last odd sf-item-9 sf-depth-1 sf-no-children"><a href="/webforms" title="" class="sf-depth-1"><span>Submit Your News</span></a></li></ul>        </div>

    </div>
</div>
  </div>
            </nav>
        </div>
    </div>

    <div class="main-menu-second-level-wrapper clearfix">
        <div class="main-menu-second-level-wrapper-inner">
            <nav id="main-menu-second-level">
                <div class="region region-main-menu-second-level">
    <div id="block-simpleads-ad-groups-416"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-416', 416, 1);
  </script>
    <div class="simpleads-416"></div>

    
</div>
        </div>

    </div>
</div>
  </div>
            </nav>
        </div>
    </div>

<div id="page">
    <div class="page-inner container_12">

        <!-- Main Content -->
        <div class="main-content-wrapper clearfix">
            <div class="main-content-wrapper-inner">
                <section id="main-content">

                    <div class="main">
                        <div class="main-inner grid_8">

                          
                                                                                                                                    <div class="region region-content">
    <div id="block-system-main"
     class="block block-system">
    <div class="block-inner">

                  
        <div class="content">
          <article id="node-195245"
         class="node node-video node-promoted last last clearfix" about="/eastland-telegram/jon-glenn-candidate-eastland-county-jp-pct-1" typeof="sioc:Item foaf:Document">

  
        <div class="field-video">
        <div class="field field-name-field-video field-type-video-embed-field field-label-hidden"><div class="field-items"><div class="field-item even">
<div class="embedded-video">
  <div class="player">
    <iframe class="" width="618px" height="380px" src="//www.youtube.com/embed/Opxnv6X2mPY?width%3D618px%26amp%3Bheight%3D380px%26amp%3Btheme%3Ddark%26amp%3Bautoplay%3D0%26amp%3Brel%3D0%26amp%3Bshowinfo%3D1%26amp%3Bmodestbranding%3D0%26amp%3Biv_load_policy%3D1%26amp%3Bautohide%3D2%26amp%3Bvq%3Dhd720%26amp%3Bwmode%3Dopaque" frameborder="0" allowfullscreen></iframe>  </div>
</div>
</div></div></div>      </div>
  
    <div class="node-content-wrapper">

      
      
                <h1 class="title">Jon Glenn Candidate For Eastland County JP Pct. #1 </h1>
      
      <span property="dc:title" content="Jon Glenn Candidate For Eastland County JP Pct. #1 " class="rdf-meta element-hidden"></span>
                <div class="submitted">
              <span class="date"><span property="dc:date dc:created" content="2018-02-05T13:00:56-06:00" datatype="xsd:dateTime">Mon, 02/05/2018 - 1:00pm</span></span>
            <span rel="sioc:has_creator"><span class="username" xml:lang="" about="/users/eastland1" typeof="sioc:UserAccount" property="foaf:name" datatype="">Eastland1</span></span>          </div>
      
        <div class="content">
          <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><strong>Conservative Republican Candidate Jon Glenn for Justice of the Peace Pct. 1</strong></p>
<p><strong>Equality, Fairness, Respect</strong></p>
<p><strong>Early Voting - Feb.20 - March 2</strong></p>
<p><strong>Election Day- March 6</strong></p>
<p>Paid Political Ad paid by Jon Glenn</p>
</div></div></div>        </div>

                    
                <nav class="taxonomy">
              <div class="taxonomy-inner clearfix">
                <div class="field field-name-field-section field-type-taxonomy-term-reference field-label-above"><div class="field-label">Section:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/eastland-telegram" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype=""><span>Eastland Telegram</span></a></div></div></div>              </div>
          </nav>
      
                <nav class="taxonomy">
              <div class="taxonomy-inner clearfix">
                              </div>
          </nav>
      
    </div>

</article>

        </div>

    </div>
</div>
  </div>
                                                  </div>

                        <aside class="sidebar second-sidebar grid_4 clearfix">
                            <div class="region region-sidebar-first">
    <div id="block-simpleads-ad-groups-494"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-494', 494, 2);
  </script>
    <div class="simpleads-494"></div>

    
</div>
        </div>

    </div>
</div>
<div id="block-block-1"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <div style="width: 300px;"><iframe style="display: block;" src="//cdnres.willyweather.com/widget/loadView.html?id=61737" width="300" height="228" frameborder="0" scrolling="no"></iframe><a style="text-indent: -9999em;position: relative;height: 20px;z-index: 1;display: block;margin: -20px 0 0 0" href="http://www.willyweather.com/tx/eastland-county/eastland.html" rel="nofollow">Eastland Weather</a></div>        </div>

    </div>
</div>
<div id="block-views-featured-view-block"
     class="block block-views">
    <div class="block-inner">

                      <h3 class="title">
              <span><a href="/recent-videos" class="block-title-link"><span>VIDEO</span></a></span></h3>
            
        <div class="content">
          <div class="view view-featured-view view-id-featured_view view-display-id-block view-dom-id-2efbb8d1230ed6ad0c8e7fa8574b1b23">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-video">        <div class="field-content">
<div class="embedded-video">
  <div class="player">
    <iframe class="" width="260px" height="180px" src="//www.youtube.com/embed/YVdZpgxalJw?width%3D260px%26amp%3Bheight%3D180px%26amp%3Btheme%3Ddark%26amp%3Bautoplay%3D0%26amp%3Brel%3D0%26amp%3Bshowinfo%3D1%26amp%3Bmodestbranding%3D0%26amp%3Biv_load_policy%3D1%26amp%3Bautohide%3D2%26amp%3Bvq%3Dhd720%26amp%3Bwmode%3Dopaque" frameborder="0" allowfullscreen></iframe>  </div>
</div>
</div>  </div>  
  <div class="views-field views-field-title">        <h3 class="field-content"><a href="/eastland-telegram/eastland-county-commissioners-pct-2-debate-part-4-4"><span>Eastland County Commissioners Pct. 2 Debate Part 4 of 4</span></a></h3>  </div>  </div>
    </div>
  
  
  
      
<div class="more-link">
  <a href="/recent-videos">
    More Recent Videos  </a>
</div>
  
  
  
</div>        </div>

    </div>
</div>
<div id="block-etype-e-edition"
     class="block block-etype">
    <div class="block-inner">

                  
        <div class="content">
          
<p class="rtecenter"><a href="https://etypeservices.com/Eastland TelegramID147/"><img src="https://etypeservices.com/LandingPageImages/Eastland Telegram/currentpg1.jpg"></a></p><h4 class="rtecenter"><a href="https://etypeservices.com/Eastland TelegramID147/">Click here to read Eastland County Today</a></h4>
        </div>

    </div>
</div>
<div id="block-simpleads-ad-groups-421"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-421', 421, 1);
  </script>
    <div class="simpleads-421"></div>

    
</div>
        </div>

    </div>
</div>
<div id="block-etype-facebook"
     class="block block-etype">
    <div class="block-inner">

                      <h3 class="title">
              <span>Facebook</span></h3>
            
        <div class="content">
          
 <div class="fb-page" data-href="https://www.facebook.com/eastlandcountynews" data-tabs="timeline" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"></div>
            </div>

    </div>
</div>
<div id="block-dfp-tpa-northsidebar"
     class="block block-dfp">
    <div class="block-inner">

                  
        <div class="content">
          <div id="dfp-ad-tpa_northsidebar-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-tpa_northsidebar" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-tpa_northsidebar");
    });
  </script>
</div>
</div>        </div>

    </div>
</div>
<div id="block-simpleads-ad-groups-422"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-422', 422, 1);
  </script>
    <div class="simpleads-422"></div>

    
</div>
        </div>

    </div>
</div>
  </div>
                                                  </aside>
                    </div>

                </section>
            </div>
        </div>

        <div class="region region-content-bottom">
    <div id="block-dfp-tpa-northleaderboard"
     class="block block-dfp">
    <div class="block-inner">

                  
        <div class="content">
          <div id="dfp-ad-tpa_northleaderboard-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-tpa_northleaderboard" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-tpa_northleaderboard");
    });
  </script>
</div>
</div>        </div>

    </div>
</div>
  </div>

                <div class="postscript-wrapper clearfix">
              <div class="postscript-wrapper-inner">
                  <div class="postscript-wrapper-inner-inner">
                      <section id="postscript">
                          <div class="grid_4">  <div class="region region-postscript-1">
    <div id="block-block-3"
     class="block block-block">
    <div class="block-inner">

                      <h3 class="title">
              <span>Eastland County Today</span></h3>
            
        <div class="content">
          <div>
<p>215 S. Seaman St.<br />
Eastland, Texas 76448<br />
(254) 629-1707</p>
</div>
        </div>

    </div>
</div>
  </div>
</div>
                          <div class="grid_4">  <div class="region region-postscript-2">
    <div id="block-menu-block-2"
     class="block block-menu-block">
    <div class="block-inner">

                      <h3 class="title">
              <span>Site Links</span></h3>
            
        <div class="content">
          <div class="menu-block-wrapper menu-block-2 menu-name-main-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="first leaf menu-mlid-656"><a href="/" title=""><span>Home</span></a></li>
<li class="leaf has-children menu-mlid-2503"><a href="/eastland-telegram" title="Eastland Telegram"><span>Eastland Telegram</span></a></li>
<li class="leaf has-children menu-mlid-1284"><a href="/cisco-press" title="Cisco Press"><span>Cisco Press</span></a></li>
<li class="leaf has-children menu-mlid-2422"><a href="/ranger-times" title="Ranger Times"><span>Ranger Times</span></a></li>
<li class="leaf has-children menu-mlid-2339"><a href="/rising-star" title="Rising Star"><span>Rising Star</span></a></li>
<li class="leaf has-children menu-mlid-2587"><a href="/gorman-progress" title="Gorman Progress"><span>Gorman Progress</span></a></li>
<li class="leaf has-children menu-mlid-2650"><a href="https://etypeservices.com/SWF/LocalUser/Etypeclass1/Magazine30252/Full/index.aspx?II=30252" title=""><span>Classifieds</span></a></li>
<li class="leaf menu-mlid-2170"><a href="/contact" title=""><span>Contact Us</span></a></li>
<li class="last leaf menu-mlid-2660"><a href="/webforms" title=""><span>Submit Your News</span></a></li>
</ul></div>
        </div>

    </div>
</div>
  </div>
</div>
                          <div class="grid_4">  <div class="region region-postscript-3">
    <div id="block-etype-follow"
     class="block block-etype">
    <div class="block-inner">

                      <h3 class="title">
              <span>Follow Us</span></h3>
            
        <div class="content">
          <div class="facebook"><a href="https://www.facebook.com/eastlandcountynews">Like us on Facebook</a></div><div class="rss"><a href="/rss.xml">RSS Feed</a></div>        </div>

    </div>
</div>
  </div>
</div>
                      </section>
                                            <section id="postscript_banner">
                            <div class="grid_12">  <div class="region region-postscript-banner">
    <div id="block-block-35"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <noscript>
<p>Coupons powered by <a href="https://www.coupons.com?pid=13903&nid=10&zid=xh20&bid=1417300001">Coupons.com</a></p>
</noscript>
<script id="scriptId_718x940_170461" type="text/javascript" src="//bcg.coupons.com/?scriptId=170461&bid=1417300001&format=718x940&bannerType=3">
</script>        </div>

    </div>
</div>
  </div>
</div>
                        </section>
                                      </div>
              </div>
          </div>
                </div>
</div><!-- page -->
<script type="text/javascript" src="https://www.eastlandcountytoday.com/sites/eastlandcountytoday.etypegoogle5.com/files/js/js_MLVgtzZ1ORq9krYqkeOsRay6ou_T-0QZytivuM9tTT8.js"></script>
</body>
</html>
